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Appendix B * 
Import (CAD Transfer) Mode Keyboard Shortcuts 

 
Mode-Changing Keys 

 
   E Switch to Edit mode (press twice for Entry mode) 

 
   F Switch to Profile View mode 

 
   H Switch to Highway mode (if available) 

 
   W Switch to Plan View mode 

 
   V Switch to 3D View mode 

 
   P Switch to Print View mode 

 
   X Gradework 4D only: Switch to Materials/Underground mode 

 
 
Drop-Down Menu Keys 
 

Alt-D Show Display menu 
 
Alt-E Show Edit menu 
 
Alt-F Show File menu 
 
Alt-G Show Guide menu 
 
   G Display last-used Data Entry Guide dialog 
 
Alt-O Show Options menu 
 
Alt-V Show View menu 
 
Alt-W Show Window menu 

 
 
PDF Multi-Page Preview Dialog Keys 

 
Tab Display image corresponding to number typed in Page Number field 

 

Space Zoom in/out at Arrow  pointer location over currently displayed dialog image 
 
 
PDF Plan Image Vectorization Keys 

 
Esc Cancels Analyzing PDF Data phase of raster-to-vector conversion process (if process is proceeding too slowly—

typically due to large numbers of dashed contours) 
 
 
Data-Display Keys 

 
Home Restore default display setting (zoom to extents of visible data) 

 

Space Zoom in/out at Arrow  pointer location 

 

Page Up Increase zoom at Arrow  pointer location 

* A PDF copy of this Appendix B is included in the Day 3 zip package (see Appendix C).  Shortcut key help 

pages are also available within the AGTEK program, including an abbreviated printable reference sheet 
(Help > Hot Key Help from program menu or at www.agtek.com/help/gw/keyboard_shortcuts.htm). 189 
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Appendix B 
Import (CAD Transfer) Mode Keyboard Shortcuts (Cont.) 

 
Data-Display Keys (Cont.) 

 

Page Dn Decrease zoom at Arrow  pointer location 

 
Alt-B Show Import Layers dialog (check/uncheck layers to show/hide on screen display).  Other Functions: (1) press Shift or 

Ctrl and double-Left click a layer name to Hide All But on screen display, (AGTEK 3D only) keep Arrow  pointer in 

dialog and tap  or  key to incrementally add one additional layer to screen display, Left click any other layer to restore 
original layer display; (2) Range layer selection: press Shift and Left click a layer name and repeat at another layer 

name to range-select the bounded layers (click any layer checkbox in the selected range to invert their show/hide screen 
display); (3) Cumulative layer selection: press Ctrl and Left click desired layer names for cumulative selection (click any 
selected-layer checkbox to invert their show/hide screen display).  [Note: Range and Cumulative selected layers are 
helpfully back-shaded in AGTEK 3D but back-shading is disabled in current versions of AGTEK 4D due to a program 
bug.] 

  
Alt-H Hide currently selected data (press Alt-H again to redisplay the hidden data) 

 
Alt-S Show all currently hidden data 
 
   T Toggle background image display off/on 
 
   R Rotate displayed background image 45 degrees right 
 
   L Rotate displayed background image 45 degrees left 

 
    M Toggle shading (white/gray) of background PDF plan image; toggle brightness of other background images 

 
  F2 Toggle data point “Plus Marks” on/off 

 

     Pan up / Pan down 
 

    Pan right / Pan left 
 

 
Data-Selection/Transfer Keys 

 
Shift Press Shift for cumulative select (deselect) of individual CAD layer objects 
 
Ctrl Press Ctrl for cumulative select (deselect) of CAD layers 
 
Esc Deselect any selected data 
 

Delete Delete currently selected data 
 
   S Send currently selected data to destination Surface/Layer 

 
   Z AGTEK 3D only: Toggle zoom to selected point on/off (use Options > Sticky Zoom menu in AGTEK 4D) 

 
Ctrl-Z Undo last function 

 
Ctrl-Y Redo last undo 
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Appendix B 
Edit Mode Keyboard Shortcuts 

 
Mode-Changing Keys 

 
   A Switch to Import (CAD Transfer) mode 
 
   E Switch to Entry mode 

 
   F Switch to Profile View mode 

 
   H Switch to Highway mode (if available) 

 
   W Switch to Plan View mode 

 
   V Switch to 3D View mode 
 
   P Switch to Print View mode 

 
   X Gradework 4D only: Switch to Materials/Underground mode 

 
 
Drop-Down Menu Keys 

 
Alt-E Show Edit menu 
 
Alt-G Show Guide menu 
 
   G Display last-used Data Entry Guide dialog 
 
Alt-W Show Window menu 
 

 
Data-Selection/Editing Keys 

 
Shift Press Shift for cumulative select (deselect) of individual objects (same function as Ctrl).  Other Uses: (1) see Ctrl-L 

for cumulative Label Select using Shift; (2) to renumber Benchmarks for AGTEK 3D’s paper plan scaling sequence, 
Left click desired Benchmark 1, press Shift and Left click desired Benchmark 2, press Shift and Left click desired 
Benchmark 3, Right click then click OK in Reorder Benchmarks dialog. 

 
Ctrl Press Ctrl for cumulative select (deselect) of individual objects (same function as Shift). Special case: see Ctrl-L for 

cumulative Label Select. 
 
Delete Options: (1) Delete selected object(s); (2) Delete selected segment(s) of object  
 
Esc Options: (1) Deselect all selected data; (2) AGTEK 4D only: While Template is being applied, press once to suppress 

line plotting for faster application (useful with long reference alignments) or press twice to cancel Template 
application   

 
   S Toggle “Snap” function on/off (see Gradework 4D‘s F7 snap option on next page)  

 
Alt AGTEK 4D only: When Stake List Editor is open, press Alt while selecting base point for offset stake guide lines, 

release Alt then select desired stake point for reoriented offset stake guide lines 
 
Alt-A Select all data on active surface/layer 
 
Alt-H Hide currently selected data (press Alt-H again to redisplay last hide) 

 
Alt-S Show all hidden data (any layers Unchecked in Alt-B dialog remain hidden)  
 
Alt-X Region selection tree dialog (Perimeter/Area/Region layers only) 
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Appendix B 
Edit Mode Keyboard Shortcuts (Cont.) 

 
Data-Selection/Editing Keys (Cont.) 

 
Ctrl-A Convert selected data to/from annotation 

 
Ctrl-C Copy data selected on active surface/layer 
 
Ctrl-F Fillet (1) converts a selected angle point to user-defined radius or (2) arc-joins the gap between two selected lines.  

See AGTEK’s Fillet video at www.agtek.com/video.html?id=545. 
 
Ctrl-V Paste copied/cut data to active surface/layer 
 
Ctrl-J Join selected broken line segments (select Options > Bridge Gap Distance from menu to set maximum horizontal 

and vertical Join gap distances). If multiple lines are selected and Joined, they will remain selected for ease of hiding 
(Alt-H). See AGTEK videos at www.agtek.com/video.html?id=280 and www.agtek.com/video.html?id=607. 

 
Ctrl-L Run Label Select utility to select all objects on current layer matching a selected object’s Line Label.  Options: (1) 

after running label select, press Shift or Ctrl to pick an unselected object, then press Ctrl-L for cumulative label 
selection (repeat as needed); (2) if no object is selected when Ctrl-L is pressed, a pop-up Label Selection dialog 
allows label selection by specifying a Line Label, a Point Label or (in Gradework 4D only per related video at 
https://bit.ly/41X9Jxy) a Group name (Groups only apply to Stripping Area and Report Region/Sectional Area object 
selections); (3) the Label Selection dialog supports use of “*” (multi-character) and “?” (single-character) wildcards for 
partial Line or Point Label matching; (4) the Label Selection dialog (in AGTEK 4D only) will select all unlabeled 
objects on current layer if the Line or Point Label field is left blank/empty (in Gradework 4D only, Stripping Area and 
Report Region/Sectional Area objects with no Group assigned are selected if “UNNAMED” is used in Group field). 

 
   K AGTEK 4D only: (1) If one or more Report Regions/Sectional Areas are selected, press K to display the Report 

Regions/Sectional Areas editing dialog;  (2) If one or more Stripping Areas are selected, press K to display the 
Stripping Areas editing dialog (see related video at https://bit.ly/41X9Jxy). 

 
   L AGTEK 4D only: (1) Displays Edit Point/Line Labels dialog to add/change labels for all selected objects (if 3D view is 

on, press T before pressing L); Gradework 4D only: (2) if Stripping Areas are selected, use the dialog to modify Line 
Label, Group name and Stripping Depth; Gradework 4D only: (3) if Report Regions are selected, use the dialog to 
modify Line Label, Group name and Fill Factor; Gradework 4D only: (4) if Sectional Areas are selected, use the 

dialog to modify Line Label, Group name and Sectional Depth (see Gradework video at https://bit.ly/41X9Jxy). 
 
Ctrl-M Move start point of closed object to selected data point 
 
Ctrl-O Run Offset Line Editor for selected data line(s) 
 
Ctrl-P AGTEK 3D only: Run Auto Pad utility (use Ctrl-W in AGTEK 4D); AGTEK 4D only: Ctrl-P runs Apply Template utility 

with selected line(s) 
 
Ctrl-R AGTEK 4D only: (“Swap Ends”) Reverses the point entry order of any selected lines (use Ctrl-S in AGTEK 3D)  
 
Ctrl-S AGTEK 3D only: (“Swap Ends”) Reverses the point entry order of any selected lines (use Ctrl-R in AGTEK 4D)  

 
Ctrl-S AGTEK 4D only: Save current ESW job file (same function as File > Save from menu)  
 
Ctrl-T Trim visible (not hidden) lines that intersect selected line(s)/perimeter.  Options: (1) if a single closed line is selected, 

available options are “Trim Only”, “Remove Lines Inside” (trim and delete all lines inside selected line), and “Remove 
Lines Outside” (trim and delete all lines outside selected line); (2) the Remove Lines Inside/Outside variant under 
Option 1 will apply to any hidden lines having “Break Line” as the Line Label; (3) if pairs of lines that were created 
with the same Offset Line (or Apply Template) utility reference are selected, the option to “Trim Between Lines” (trim 
and delete all lines between selected pairs of Offset/Template lines) is available.  

  
Ctrl-W AGTEK 4D only: Run Auto Pad utility (use Ctrl-P in AGTEK 3D)  
 
Ctrl-X Break line at selected data point 
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Appendix B 
Edit Mode Keyboard Shortcuts (Cont.) 

 
Data-Selection/Editing Keys (Cont.) 

 
Ctrl-Y Redo last undo 

 
Ctrl-Z Undo last command (select Options > Max Undo Levels from menu to set number of undo levels) 

 

  F5 Determines the interpolated elevation of a data line at the Arrow  pointer tip, inserts a new data point on the data 

line at the determined elevation, and breaks the data line at the new data point (can also be used to insert/break 
other layer objects)—use F6 if break is not desired at new point 

 
  F6 Similar function as F5, but the data line is not broken at the new data point (can also be used to add additional points 

on other layer objects) 
    
  F8 Options: (1) Auto-increment elevation snap for 2D-3D CAD contour conversion; (2) AGTEK 4D only: When Stake List 

Editor is open, adds specified point to Stake List 
 

  F7 Move a selected point to Arrow  pointer’s tip.  Variations: (1) press and hold F7 then move mouse to "drag" the 

selected point to a new location (release F7 at desired drag-to location); (2) F7 can be used to extend or shorten a 

selected line’s end segment by the parallel distance to Arrow pointer’s tip when the first (or last) two points of the 
selected line are drag-selected in the Point Scroll (resulting extended/shortened end-point elevation is recalculated 
using original slope between the two drag-selected points ); (3) in AGTEK 4D only, when F7 is used to move points 
on combined-entry Report Region/Sectional Area objects, moving a point on one object automatically moves the 
other object’s corresponding point; (4) in Gradework 4D only, with Snap enabled (press S), select a point to move, 

position Arrow  pointer tip at the desired move-to location (either a data point or a line segment between two data 
points) then press F7 to complete (the moved point is snapped to the move-to point/segment and its elevation is 
changed to match the move-to location’s elevation). See AGTEK’s F7 video at https://youtu.be/xRzd60zssxs. 

 

  F9 Elevation snap copies elevation from data point nearest the Arrow  pointer to the currently selected data point 

 
 F11 Gradework 4D only: Shrink-Wrap utility horizontally conforms (“shrinks”) selected closed line(s) on any Layer to the 

bounded data of the Data Lines Layer for the active Surface; shrink-wrapped data remains on its respective starting 
Layer but it can be copied/cut and pasted to any desired destination Layer such as Perimeters, Stripping Areas, 
Report Regions, etc. (for details and examples, see AGTEK’s F11 video at www.agtek.com/video.html?id=592). 

    

0 – 9 (If Arrow  pointer is in the Point Scroll) Numeric keys (or “+”, “-“, “.”) modify a selected data line point elevation via 

the Point Editor. 
 

A – Z (If Arrow  pointer is in the Point Scroll) Alphabetic keys display the Point/Line Label Editor. 
 

 
Data-Display Keys for Plan View Overlay 

 
   O Toggle plan view overlay off/on when 3D view is displayed 
 

Insert AGTEK 4D only: Sequentially re-load aligned background images for Arrow  pointer location (if expected image 

does not re-load, verify corresponding image border is not hidden) 
    
Ctrl Gradework 4D only: With Image Selection dialog displayed, press and hold Ctrl to cumulatively select multiple 

background images in dialog 
    
Shift Gradework 4D only: With Image Selection dialog displayed, press and hold Shift to select range of background 

images in dialog 
 
   T Cycle display of 3D Terrain view and any current/loaded background image; Gradework 4D only: Cycle display 

between Slope Colors and current/loaded background image (3D Terrain view is disabled if Slope Color display is 
enabled) 
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Appendix B 
Edit Mode Keyboard Shortcuts (Cont.) 

 
Data-Display Keys for Plan View Overlay (Cont.) 

 
   J AGTEK 4D only: Toggle current/loaded background image off/on 
 
   M Toggle shading (white/gray) of background PDF plan image; toggle brightness of other background images 
 
  F2 AGTEK 4D only: Toggle data point “Plus Marks” on/off 

 
   C Toggle compass display and location (on, left, center, right, off) 
 
    I Display Length and Area information for any selected object(s); AGTEK 4D only: If no objects are selected, re-loads 

aligned background image for Arrow  pointer location (same function as Insert) 

 
Ctrl-I (Same function as I) Display Length and Area information for any selected object(s); AGTEK 4D only: If no objects 

are selected, re-loads aligned background image for Arrow  pointer location (same function as Insert) 
 
   L AGTEK 3D only: (with 3D Terrain View off) centers plan-view display on currently-selected point (R provides this 

function in AGTEK 4D) 
 
   R (with 3D Terrain View off) centers plan-view screen on currently-selected point 

 
   Z AGTEK 3D only: Toggle zoom to selected point on/off (use Options > Sticky Zoom menu in AGTEK 4D) 

 
Alt-B Show Layers dialog (check/uncheck layers to show/hide on screen display) 
 
Alt-F Toggle area/region hatch patterns on/off 
 
Alt-H Hide currently selected data 

 
Alt-P Send current screen view to Print Page and switch to Print View mode 
 
Alt-S Show all hidden data (any layers Unchecked in Alt-B dialog remain hidden) 
 
Alt-V Toggle background layers off/on 
 
Home Zoom to extents of visible plan view overlay data 

 

Space Zoom on/off at Arrow  pointer location 

 

Page Up Increase zoom at Arrow  pointer location 

 

Page Dn Decrease zoom at Arrow  pointer location 

 

     Pan up / Pan down 
 

     Pan right / Pan left 
 
 

Data-Display Keys for 3D Terrain View 
 
   T Cycle display of 3D Terrain view and any current/loaded background image; Gradework 4D only: Cycle display 

between Slope Colors and current/loaded background image (3D Terrain view is disabled if Slope Color display is 
enabled) 

    
   C Toggle compass display and location (on, left, center, right, off) 
 
   B Toggle 3D view between Land View (close perspective) and Sky View (distant perspective) 
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Appendix B 
Edit Mode Keyboard Shortcuts (Cont.) 

 
Data-Display Keys for 3D Terrain View (Cont.) 

 
   L Rotate 3D view 15 degrees right (viewer turns head 15 degrees left) 
 
   R Rotate 3D view 15 degrees left (viewer turns head 15 degrees right) 
    
   U Tilt 3D view up 
 
   D Tilt 3D view down 

 
Alt-I Zoom 3D view in 
 
Alt-O Zoom 3D view out 
 
Alt-R AGTEK 3D: See R; AGTEK 4D: Shift viewer’s perspective to right (3D view shifts to left), press Home to reset 
 
Alt-L AGTEK 3D: See L; AGTEK 4D: Shift viewer’s perspective to left (3D view shifts to right), press Home to reset 

 
Alt-U Raise viewer’s perspective (lowers 3D view), press Home to reset 
 
Alt-D Lower viewer’s perspective (raises 3D view), press Home to reset 

 
Alt-P Send current screen view to Print Page and switch to Print View mode 
 
  F1 Viewer’s perspective from inside vehicle 

 
  F2 AGTEK 3D only: Viewer’s perspective from 50’ behind vehicle (use B in AGTEK 4D) 
 
  F3 Viewer’s perspective from 50’ right of vehicle 
 
  F4 Viewer’s perspective from 50’ left of vehicle 
 
 F11 Flip viewer’s perspective 180 degrees (use Ctrl-F11 in Gradework 4D) 
 
Ctrl-F11 Gradework 4D only: Flip viewer’s perspective 180 degrees (use F11 in AGTEK 3D and Earthwork 4D) 
 
Home AGTEK 3D: Re-centers plan-view display, and resets 3D view’s tilt and vertical scale; AGTEK 4D: Re-centers plan-

view display and resets 3D view’s vertical scale 
 
+ / - Increase/decrease 3D view’s vertical exaggeration 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Copyright © 2025 Earthwork Software Services, LLC. All rights reserved. www.EarthworkSoftwareServices.com



 196 

Appendix B 
Entry Mode Keyboard Shortcuts 

 

Mode-Changing Keys (with Arrow  Pointer) 

 
   A Switch to Import (CAD Transfer) mode 
 
   E Switch to Edit mode 

 
   F Switch to Profile View mode 

 
   H Switch to Highway mode (if available) 

 
   W Switch to Plan View mode 

 
   V Switch to 3D View mode 

 
   P Switch to Print View mode 

 
   X Gradework 4D only: Switch to Materials/Underground mode 

 
 

Drop-Down Menu Keys (with Arrow  Pointer) 
 
Alt-E Show Edit menu 
 
Alt-G Show Guide menu 
 
   G Display last-used Data Entry Guide dialog 
 
Alt-H Show Help menu 
 
Alt-W Show Window menu 
 

 
Data-Display Keys for Plan View Overlay 

 
   O Toggle plan view overlay off/on when 3D view is displayed 
 

Insert AGTEK 4D only: Sequentially re-load aligned background images for Arrow  or Crosshair  pointer location (if 

expected image does not re-load, verify corresponding image border is not hidden) 
 
   I AGTEK 4D only: Re-load aligned background image for pointer location (same function as Insert) 
 
Ctrl-I AGTEK 4D only: Re-load aligned background image for pointer location (same function as Insert) 
    
Ctrl Gradework 4D only: With Image Selection dialog displayed, press and hold Ctrl to cumulatively select multiple 

background images in dialog 
    
Shift Gradework 4D only: With Image Selection dialog displayed, press and hold Shift to select range of background 

images in dialog 
 
   T Cycle display of 3D Terrain view and any current/loaded background image; Gradework 4D only: Cycle display 

between Slope Colors and current/loaded background image (3D Terrain view is disabled if Slope Color display is 
enabled) 

 
   J AGTEK 4D only: Toggle current/loaded background image off/on 
 
   M Toggle shading (white/gray) of background PDF plan image; toggle brightness of other background images 
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Appendix B 
Entry Mode Keyboard Shortcuts (Cont.) 

 
Data-Display Keys for Plan View Overlay (Cont.) 

    
   C Toggle compass display and location (on, left, center, right, off) 
 
Alt-B Show Layers dialog (check/uncheck layers to show/hide on screen display) 
 

Alt-F Toggle area/region hatch patterns on/off with Crosshair  pointer (AGTEK 4D only); or Arrow  pointer (AGTEK 

3D and AGTEK 4D) 
 
Alt-P Send current screen view to Print Page and switch to Print View mode 
 
Alt-S Show all hidden data (any layers Unchecked in Alt-B dialog remain hidden) 

 

Alt-V Toggle background layers off/on (with Crosshair  pointer or Arrow  pointer) 
 
  F2 AGTEK 4D only: Toggle data point “Plus Marks” on/off 

 
Home Zoom to extents of visible plan view overlay data 

 

Space Zoom on/off at Arrow  pointer location 
 

Page Up Increase zoom at Arrow  pointer location 
 

Page Dn Decrease zoom at Arrow  pointer location 

 

     Pan up / Pan down 
 

     Pan right / Pan left 
 

 

Data-Display Keys (with Arrow  Pointer only) for 3D Terrain View 
 
   T Cycle display of 3D Terrain view and any current/loaded background image; Gradework 4D only: Cycle display 

between Slope Colors and current/loaded background image (3D Terrain view is disabled if Slope Color display is 
enabled) 

 
   C Toggle compass display and location (on, left, center, right, off) 
 
   B Toggle 3D view between Land View (close perspective) and Sky View (distant perspective) 
 
   U Tilt 3D view up 
 
   D Tilt 3D view down 

 
Alt-I Zoom 3D view in 
 
Alt-O Zoom 3D view out 

 
Alt-R Shift viewer’s perspective to right (3D view shifts to left), press Home to reset 
 
Alt-L Shift viewer’s perspective to left (3D view shifts to right), press Home to reset 

 
Alt-U Raise viewer’s perspective (lowers 3D view), press Home to reset 
 
Alt-D Lower viewer’s perspective (raises 3D view), press Home to reset 

 
Alt-P Send current screen view to Print Page and switch to Print View mode 
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Appendix B 
Entry Mode Keyboard Shortcuts (Cont.) 

 

Data-Display Keys (with Arrow  Pointer only) for 3D Terrain View (Cont.) 
 
  F1 Viewer’s perspective from inside vehicle (reset perspective with B key) 

 
  F2 AGTEK 3D only: Viewer’s perspective from 50’ behind vehicle (use B in AGTEK 4D) 
 
  F3 Viewer’s perspective from 50’ right of vehicle (reset perspective with B key) 
 
  F4 Viewer’s perspective from 50’ left of vehicle (reset perspective with B key) 
 
 F11 Flip viewer’s perspective 180 degrees (use F11 or Ctrl-F11 in Gradework 4D) 
 
Ctrl-F11 Gradework 4D only: Flip viewer’s perspective 180 degrees (use F11 in AGTEK 3D and Earthwork 4D) 
 
Home AGTEK 3D: Re-centers plan-view display, and resets 3D view’s tilt and vertical scale; AGTEK 4D: Re-centers plan-

view display and resets 3D view’s vertical scale 
 
    + Increase 3D view’s vertical exaggeration (“-“ to decrease exaggeration does not function in Entry mode)  
 
 

Data-Entry Keys 

 
   K AGTEK 4D only: (1) If surface is set to Existing, press K to display the Stripping Area entry dialog; (2) if surface is set 

to Design, press K to display the Report Region/Sectional Area entry dialog (K key is a shortcut for the corresponding 

Add Regions  toolbar button—see related videos at https://bit.ly/41X9Jxy and https://bit.ly/3Plc660). 
 
   L (1) Displays Edit Line/ Point Labels dialog to label next entry; Gradework 4D only: (2) if layer is set to Stripping Areas, 

use the dialog to enter a Stripping Area (but dialog is limited to Line Label, Group name and Stripping Depth); 
Gradework 4D only: (3) if layer is set to Report Regions, use the dialog to enter a Report Region (but dialog is limited 
to Line Label, Group name and Fill Factor); Gradework 4D only: (4) if layer is set to Sectional Areas, use the dialog to 
enter a Sectional Area (but dialog is limited to Line Label, Group name and Sectional Depth)—see related Gradework 
videos at https://bit.ly/41X9Jxy and https://bit.ly/3Plc660. 

 

   R Fillet (radius) drawing tool; with Crosshair  pointer active, (1) enter first PC (start of curve) point, (2) enter PI point 
(point of intersection), (3) type “Rx” (where “x” represents desired curve radius value) and (4) enter second PC (end 

of curve) point. 
 
   S Toggle “Snap” function on/off (if applicable, Tablet Entry must be disabled via Options > Tablet Entry from menu) 
 
Ctrl-Q AGTEK 3D only: Cycles Status Bar display between Distance/Slope (default), Distance/OG Elevation, Discreet 

Distance/Slope, and Discreet Distance/Angle (in AGTEK 4D, select Options > Modeling Options > [Option] from 
menu).  See related Q and F12 keys below). 

 

   Q (With Arrow  or Crosshair  pointer) Restores Status Bar display to default Distance/Slope mode (see the Ctrl-Q 
and F12 key notes, and related video at https://bit.ly/3WqD2oQ). 

 
   X No data-entry function (replaced by Q above); Gradework 4D only: X switches to Materials/Underground mode. 
 

Ctrl-V Paste copied/cut data to active surface/layer (with Arrow  pointer) 
 

Ctrl-Y Redo last undo (with Arrow  pointer) 
 

Ctrl-Z Undo last command, select Options > Max Undo Levels from menu to set number of undo levels (with Arrow  

pointer) 
 

Backspace During entry of an object on any layer: press once to delete object’s last-entered point, press again to delete next 
point (or press and hold Backspace to sequentially “stream” delete multiple points) 

Copyright © 2025 Earthwork Software Services, LLC. All rights reserved. www.EarthworkSoftwareServices.com

https://bit.ly/41X9Jxy
https://bit.ly/3Plc660
https://bit.ly/41X9Jxy
https://bit.ly/3Plc660
https://bit.ly/3WqD2oQ


 199 

Appendix B 
Entry Mode Keyboard Shortcuts (Cont.) 

 
Data-Entry Keys (Cont.) 

 

  F6 Snaps a data point to a data line segment by determining the segment’s interpolated elevation at the Crosshair  
pointer location (using F6 snap in AGTEK 4D inserts a corresponding data point on the referenced line segment).  F6 

can also be used in AGTEK 4D to match invert elevations on Pipe Lines layer. 
 

  F8 Snaps to nearest data point within snap radius of Crosshair  pointer (select Options > Snap Size from menu and 
check Draw Snap Circle box to display snap radius circle).  If snapping to a data line, the elevation will match that of 

the snapped data point; if snapping to an annotation line, the user may type a desired elevation or allow the program 
to interpolate a value.  Also used for Line/Area snap with CAD data or when entering Stripping and Sectional Areas. 

 
  F9 Elevation snap is used to “read and type” the elevation from a CAD text label (or data line point) and then attach the 

elevation to a new point on a data line (with Crosshair  pointer) 
 
  F10 AGTEK 4D only: Calculates and enters pipe (lateral) invert elevation on Pipe Lines layer as vertical offset from 

interpolated active surface elevation at Crosshair  pointer (type negative offset value “-x” then press F10) 

 

  F12 Reorients horizontal entry reference relative to the line segment nearest the Arrow  or Crosshair  pointer and sets 
Status Bar display to Discreet Distance/Angle mode (see related Ctrl-Q and Q keys above).  See AGTEK’s videos at 
https://bit.ly/3WqD2oQ, www.agtek.com/video.html?id=267 and www.agtek.com/video.html?id=355 for F12 

application examples. 
 
Shift Press and hold for contour streaming using Left mouse button when “heads-up” digitizing from PDF or other 

background image 
 

A – Z (If Arrow  or Crosshair  pointer is in the Point Scroll) Alphabetic keys display the Point/Line Label Editor. 

 
Ctrl-S AGTEK 4D only: Save current ESW job file (same function as File > Save from menu)  
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Appendix B 
Profile View Mode Keyboard Shortcuts 

 
Mode-Changing Keys 

 
   A Switch to Import (CAD Transfer) mode 
 
   E Switch to Edit mode (press twice for Entry mode) 

 
   H Switch to Highway mode (if available) 

 
   W Switch to Plan View mode 

 
   V Switch to 3D View mode 

 
   P Switch to Print View mode 

 
   X Gradework 4D only: Switch to Materials/Underground mode 

 
 
Drop-Down Menu Keys 

 
Alt-D Show Display menu 
 
Alt-E Show Edit menu 
 
Alt-F Show File menu 
 
Alt-G Show Guide menu 
 
   G Display last-used Data Entry Guide dialog 
 
Alt-H Show Help menu 
 
Alt-O Show Options menu 
 
Alt-U Show Utility menu 
 
Alt-V AGTEK 3D only: Show View menu 
 
Alt-W Show Window menu 
 

 

Profile-Entry Keys (with Crosshair  Pointer Active) 

 
  F6 Snaps to a data line when there is no data point to snap to 

 

  F8 Snaps to the data point nearest to the Crosshair  pointer; same function as Left click Mouse Snap 
 

Backspace During entry of profile alignment: press once to delete profile’s last-entered point, press again to delete next point (or 
press and hold Backspace to sequentially “stream” delete multiple profile points) 

 
 
Data-Editing Keys 

 
Delete Delete selected profile line 
 
Ctrl-Y Redo last undo 

 
Ctrl-Z Undo last function 
 
Ctrl-S AGTEK 4D only: Save current ESW job file (same function as File > Save from menu)  
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Appendix B 
Profile View Mode Keyboard Shortcuts (Cont.) 

 
Data-Display Keys 

 

Insert AGTEK 4D only: Sequentially re-load aligned background images for Arrow  or Crosshair  pointer plan-view 

location (if expected image does not re-load, verify corresponding image border is not hidden) 
    
Ctrl Gradework 4D only: With Image Selection dialog displayed, press and hold Ctrl to cumulatively select multiple 

background images in dialog 
    
Shift Gradework 4D only: With Image Selection dialog displayed, press and hold Shift to select range of background 

images in dialog 
 
   T Cycle display of cut/fill color shading and any current/loaded background image (Gradework 4D only: Cycle display 

between Slope Colors and current/loaded background image, cut/fill color shading is disabled if Slope Color display is 
enabled) 

    
   J AGTEK 4D only: Toggle current/loaded background image off/on 
 
   M Toggle shading (white/gray) of background PDF plan image; toggle brightness of other background images 
    
  F2 AGTEK 4D only: Toggle data point “Plus Marks” on/off 

 
   C Toggle compass display and location (on, left, center, right, off) 
 
   Z Toggle “Sticky Zoom” (to selected point) on/off 
 
Alt-B Show Layers dialog (check/uncheck layers to show/hide on screen display) 
 
Alt-P Send selected profile to Print Page and switch to Print View mode 

 
Home Zoom to extents of visible plan view overlay data 

 

Space Zoom on/off at Arrow  pointer location 

 

Page Up Increase zoom at Arrow  pointer location 

 

Page Dn Decrease zoom at Arrow  pointer location 

 

     Pan up / Pan down 
 

     Pan right / Pan left 
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Appendix B 
Plan View Mode Keyboard Shortcuts 

 
Mode-Changing Keys 

 
   A Switch to Import (CAD Transfer) mode 
 
   E Switch to Edit mode (press twice for Entry mode) 

 
   F Switch to Profile View mode 

 
   H Switch to Highway mode (if available) 

 
   P Switch to Print View mode 

 
   V Switch to 3D View mode 

 
   X Gradework 4D only: Switch to Materials/Underground mode 

 
 
Drop-Down Menu Keys 

 
Alt-D Show Display menu 
 
Alt-E Show Edit menu 
 
Alt-G Show Guide menu 

 
   G Display last-used Data Entry Guide dialog 
 
Alt-H Show Help menu 
 
Alt-O Show Options menu 
 
Alt-U Show Utility menu 
 
Alt-V AGTEK 3D only: Show View menu 
 
Alt-W Show Window menu 
 

 
Volume Calculation Keys 

 
Ctrl-A AGTEK 3D only: Create bounding area for Report Region volume calculations 

 
Ctrl-V AGTEK 3D only: Run Report Region area volume calculations 

 
Alt-A AGTEK 4D only: Create bounding area for Report Region volume calculations 
 
Alt-V AGTEK 4D only: Run Report Region area volume calculations 

 
Ctrl-B Run Balance Region area volume calculations 

 
Ctrl-S Run Balance Region Horizontal Slice (vertical interval) volume calculations 

 
Esc Cancel volume calculations 

 
Space Pause/resume volume calculations 
 
   I On pause (see Space), displays incremental cross-section “walk-through” 
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Appendix B 
Plan View Mode Keyboard Shortcuts (Cont.) 

 

Data-Entry Keys (with Crosshair  Pointer Active) 

 
  F6 Snaps to a data line when there is no data point to snap to 

 

  F8 Snaps to the data point nearest to the Crosshair  pointer (can also be used for Line snap and Area snap); same 
function as Left click Mouse Snap 

 
 
Data-Editing Keys 

 
Ctrl-Y Redo last undo 

 
Ctrl-Z Undo last function 
 
Ctrl-S AGTEK 4D only: Save current ESW job file (same function as File > Save from menu)  
 

 
Data-Display Keys 

 
Insert AGTEK 4D only: Sequentially re-load aligned background images for pointer location (if expected image does not re-

load, verify corresponding image border is not hidden) 
    
Ctrl Gradework 4D only: With Image Selection dialog displayed, press and hold Ctrl to cumulatively select multiple 

background images in dialog 
    
Shift Gradework 4D only: With Image Selection dialog displayed, press and hold Shift to select range of background 

images in dialog 
 
   T Cycle display of cut/fill color shading and any current/loaded background image (Gradework 4D only: Cycle display 

between Slope Colors and current/loaded background image, cut/fill color shading is disabled if Slope Color display is 
enabled) 

    
   J AGTEK 4D only: Toggle current/loaded background image off/on 
 
   M Toggle shading (white/gray) of background PDF plan image; toggle brightness of other background images 
    
   O Toggle plan view layers overlay off/on 
 
  F2 AGTEK 4D only: Toggle data point “Plus Marks” on/off 

 
   C Toggle compass display and location (on, left, center, right, off) 
 
   R Update cut/fill colors 
 
   L Update cut/fill colors 

 
Alt-B Show Layers dialog (check/uncheck layers to show/hide on screen display) 
 
Alt-F Toggle area/region hatch patterns on/off 
 
Alt-P Send current screen view to Print Page and switch to Print View mode 
 
Alt-K Gradework 4D only: Captures copy of current cut/fill map’s color shading for use as a background image display in 

Edit, Entry, Profile View and Plan View modes (see T and J keys above) 
 
Home Zoom to extents of visible plan view overlay data 

 

Space Zoom on/off at Arrow  pointer location 
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Appendix B 
Plan View Mode Keyboard Shortcuts (Cont.) 

 
Data-Display Keys (Cont.) 

 

Page Up Increase zoom at Arrow  pointer location 

 

Page Dn Decrease zoom at Arrow  pointer location 

 

     Pan up / Pan down 
 

     Pan right / Pan left 
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Appendix B 
3D View Mode Keyboard Shortcuts 

 
Mode-Changing Keys 

 
   A Switch to Import (CAD Transfer) mode 
 
   E Switch to Edit mode (press twice for Entry mode) 

 
   F Switch to Profile View mode 

 
   H Switch to Highway mode (if available) 
 
   W Switch to Plan View mode 

 
   P Switch to Print View mode 

 
   X Gradework 4D only: Switch to Materials/Underground mode 

 
 
Drop-Down Menu Keys 

 
Alt-E Show Edit menu 
 
Alt-G Show Guide menu 
 
   G Display last-used Data Entry Guide dialog 
 
Alt-V AGTEK 3D only: Show View menu 
 
Alt-W Show Window menu 
 

 
Volume Calculation Keys 

 
Ctrl-A AGTEK 3D only: Create bounding area for Report Region volume calculations 

 
Ctrl-V AGTEK 3D only: Run Report Region area volume calculations 

 
Alt-A AGTEK 4D only: Create bounding area for Report Region volume calculations 

 
Alt-V AGTEK 4D only: Run Report Region area volume calculations 

 
Esc Cancel volume calculations 

 
Space Pause/resume volume calculations 

 
   I On pause (see Space), displays incremental cross-section “walk-through” 
 

 
Data-Display Keys for Plan View Overlay 

 
   O Toggle plan view overlay off/on when 3D view is displayed 
 
   C Toggle compass display and location (on, left, center, right, off) 
 
Alt-B Show Layers dialog (check/uncheck layers to show/hide on screen display) 
 
Alt-F Toggle area/region hatch patterns on/off 
 
Alt-P Send current screen view to Print Page and switch to Print View mode 
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Appendix B 
3D View Mode Keyboard Shortcuts (Cont.) 

 
Data-Display Keys for Plan View Overlay (Cont.) 

 
Home Zoom to extents of visible plan view overlay data 

 

Space Zoom on/off at Arrow  pointer location 

 

Page Up Increase zoom at Arrow  pointer location 

 

Page Dn Decrease zoom at Arrow  pointer location 

 

     Pan up / Pan down 
 

     Pan right / Pan left 
 
 

Data-Display Keys for 3D Terrain View 
 
   T Toggle 3D view off/on 
    
   Z Gradework 4D only: If 3D Terrain view is displayed (press T if not displayed) and underground pipe lines are modeled 

in the job file using Gradework’s integrated Materials-Underground module, shows/hides pipe lines on 3D Terrain 
view 

    
   C Toggle compass display and location (on, left, center, right, off) 
 
   B Toggle 3D view between Land View (close perspective) and Sky View (distant perspective) 
 
   L Rotate 3D view 15 degrees right (viewer turns head 15 degrees left) 
 
   R Rotate 3D view 15 degrees left (viewer turns head 15 degrees right) 
    
   U Tilt 3D view up 
 
   D Tilt 3D view down 

 
Alt-I Zoom 3D view in 
 
Alt-O Zoom 3D view out 

 
Alt-R Shift viewer’s perspective to right (3D view shifts to left), press Home to reset 
 
Alt-L Shift viewer’s perspective to left (3D view shifts to right), press Home to reset 

 
Alt-U Raise viewer’s perspective (lowers 3D view), press Home to reset 
 
Alt-D Lower viewer’s perspective (raises 3D view), press Home to reset 
 
Alt-P Send current screen view to Print Page and switch to Print View mode 
 
  F1 Viewer’s perspective from inside vehicle 

 
  F2 AGTEK 3D only: Viewer’s perspective from 50’ behind vehicle (use B in AGTEK 4D) 
 
  F3 Viewer’s perspective from 50’ right of vehicle 
 
  F4 Viewer’s perspective from 50’ left of vehicle 
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Appendix B 
3D View Mode Keyboard Shortcuts (Cont.) 

 
Data-Display Keys for 3D Terrain View (Cont.) 

 
 F11 Flip viewer’s perspective 180 degrees (use F11 or Ctrl-F11 in Gradework 4D) 
 
Ctrl-F11 Gradework 4D only: Flip viewer’s perspective 180 degrees (use F11 in AGTEK 3D and Earthwork 4D) 
 
Home Re-centers plan-view display, and resets 3D view’s tilt and vertical scale 
 
+ / - Increase/decrease 3D view’s vertical exaggeration 

 
 
Data-Selection Keys for 3D Terrain View 

 
Ctrl Press Ctrl and Left click 3D view to select nearest corresponding point on Data Lines overlay 

 
 
Data-Manipulation Keys for Plan View Overlay 

 
Ctrl-C Copy Reference Surface Data Lines 
 

 

Driving-Simulation Entry Keys (with Crosshair  Pointer Active) 
 

Backspace During entry of Driving Simulation path: press once to delete last-entered point, press again to delete next point (or 
press and hold Backspace to sequentially “stream” delete multiple path points) 

 
 
Other Keys 

 
Ctrl-S AGTEK 4D only: Save current ESW job file (same function as File > Save from menu)  
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Appendix B 
Volume Report Mode Keyboard Shortcuts 

 
Mode-Changing Keys 

 
   A Switch to Import (CAD Transfer) mode 
 
   E Switch to Edit mode (press twice for Entry mode) 

 
   F Switch to Profile View mode 

 
   H Switch to Highway mode (if available) 

 
   W Switch to Plan View mode 
 
   V Switch to 3D View mode 

 
   P Switch to Print View mode 

 
   X Gradework 4D only: Switch to Materials/Underground mode 

 
 
Drop-Down Menu Keys 

 
Alt-E Show Edit menu 
 
Alt-F Show File menu 
 
Alt-G Show Guide menu 
 
   G Display last-used Data Entry Guide dialog 
 
Alt-H Show Help menu 
 
Alt-O Show Options menu 
 
Alt-W Show Window menu 

 
 
Other Keys 

 
Ctrl-S AGTEK 4D only: Save current ESW job file (same function as File > Save from menu)  
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Appendix B 
Haul Report Mode Keyboard Shortcuts 

 
Mode-Changing Keys 

 
   A Switch to Import (CAD Transfer) mode 
 
   E Switch to Edit mode (press twice for Entry mode) 

 
   F Switch to Profile View mode 

 
   H Switch to Highway mode (if available) 

 
   W Switch to Plan View mode 

 
   V Switch to 3D View mode 

 
   P Switch to Print View mode 

 
   X Gradework 4D only: Switch to Materials/Underground mode 

 
 
Drop-Down Menu Keys 

 
Alt-E Display Edit menu 
 
Alt-F Display File menu 
 
Alt-G Show Guide menu 
 
   G Display last-used Data Entry Guide dialog 
 
Alt-H Display Help menu 
 
Alt-O Display Options menu 
 
Alt-W Display Window menu 

 
 
Other Keys 

 
Ctrl-S AGTEK 4D only: Save current ESW job file (same function as File > Save from menu)  
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Appendix B 
Print View Mode Keyboard Shortcuts 

 
Mode-Changing Keys 

 
   A Switch to Import (CAD Transfer) mode 
 
   E Switch to Edit mode (press twice for Entry mode) 

 
   F Switch to Profile View mode 

 
   H Switch to Highway mode (if available) 

 
   W Switch to Plan View mode 
 
   V Switch to 3D View mode 

 
   X Gradework 4D only: Switch to Materials/Underground mode 

 
 
Drop-Down Menu Keys 

 
Alt-E Display Edit menu 
 
Alt-F Display File menu 
 
Alt-G Show Guide menu 
 
   G Display last-used Data Entry Guide dialog 
 
Alt-H Display Help menu 
 
Alt-O Display Options menu 
 
Alt-W Display Window menu 
 

 
Print Object Keys 

 

   T Add text box print object (at Arrow  pointer location) 

 
Del Delete selected print object 

 
 Shift Select one print object under another print object (press and hold Shift key during selection) 

 
Tab Cycle print object selection (with any print object selected press Tab to select next object) 

 
Page Up Increase size of selected image print object 

 
Page Dn Decrease size of selected image print object 

 

     Move selected print object up / down 
 

     Move selected print object right / left 
 
 
Other Keys 

 
Ctrl-S AGTEK 4D only: Save current ESW job file (same function as File > Save from menu)  

 
 
 

Copyright © 2025 Earthwork Software Services, LLC. All rights reserved. www.EarthworkSoftwareServices.com


